?

Log in

No account? Create an account
 

Placeholders

About  

Previous Entry Placeholders Sep. 2nd, 2004 @ 03:22 am Next Entry
I saw the initial results of the photo hosting on my Friends Page today and have a bone to pick.

A picture uploaded through the interface (which the friend who was testing it (jassanja - who said it is difficult to use) bypasses placeholders. The whole reason why I even have placeholders on my Friends Page is that large pictures horizonally stretch the page and unlike up/down, left/right scrolling is slow and annoying so could you comsider not having the LJ-uploaded pics bypassing placeholders?
Leave a comment
[User Picture Icon]
From:kunzite1
Date:September 1st, 2004 10:47 am (UTC)

(Link)
and as a free user you dont really have the ability to allow for scrolling...

or do you?

*checks html source*

you might be able to avoid it using overrides such as:
GLOBAL_HEAD<=
<style type="text/css">
table ul table td div {
  overflow: auto;
}
</style>
<=GLOBAL_HEAD
this would (i hope) create a horizontal scrollbar for any entries that are wider than your window. you may need to toss in a width: 100%; to make it work properly. this isnt guaranteed to work as i havent tested it.
[User Picture Icon]
From:vanbeast
Date:September 1st, 2004 11:07 am (UTC)
(Link)
I don't think that's anything close to what they meant :P

You can enable an option that removes images over a certain size and replaces them with placeholders. In this case, that isn't working and causing the poster's page to scroll, and they want to fix that.
[User Picture Icon]
From:majinbakahentai
Date:September 1st, 2004 11:12 am (UTC)
(Link)
Yes, that is what I meant.
[User Picture Icon]
From:vanbeast
Date:September 1st, 2004 11:15 am (UTC)
(Link)
It seems to work fine for me. In order for me to try to figure out what's going on, can you give me a little more info?

- What is your placeholder settings? All images? 320x240? 640x480?
- What are the exact settings you're using in the post wizard? (number of columns, picture size, post orientation)
- How many pictures are you trying to post?
- How much text with each?

Thanks :)
[User Picture Icon]
From:majinbakahentai
Date:September 1st, 2004 11:22 am (UTC)
(Link)
This size for my placeholders is 640x480.

The rest is something I can't answer though, I was merely reading my Friends Page and noted the problem when a friend of mine was testing the fotobilder.
The post in question is located here, including discussion she and I got into about how she uploaded the picture.
[User Picture Icon]
From:vanbeast
Date:September 1st, 2004 11:25 am (UTC)
(Link)
That image is smaller than 640x480, so wouldn't be replaced with a placeholder.

The placeholder logic will replace any image that is larger than the threshold, or that doesn't specify a size in the <img> tag. That's probably the problem.
[User Picture Icon]
From:majinbakahentai
Date:September 1st, 2004 11:26 am (UTC)
(Link)
Then I supose that is why pictures smaller than that measurement get a placeholder put on them - no specified size to them?
[User Picture Icon]
From:vanbeast
Date:September 1st, 2004 11:29 am (UTC)
(Link)
Yup. I just confirmed this by looking at the source for your friend's journal, and they don't specify a width and height on the second image. That causes LiveJournal to assume it might be huge, and put a placeholder there.

If images like the first one are causing you troubles, you probably should switch your placeholder settings to 320x240. The image there was 567x426, so switching down to 320x240 should be safe in all cases (for your particular settings)
[User Picture Icon]
From:majinbakahentai
Date:September 1st, 2004 11:32 am (UTC)
(Link)
I honestly do not understand much of the technical side of LJ, something I'm sure you may have guessed, and am glad to gain some understanding in this situation.

My thanks.
[User Picture Icon]
From:kunzite1
Date:September 1st, 2004 11:14 am (UTC)

(Link)
*shrug* ... a temporary fix for the fotobilder bug?
[User Picture Icon]
From:vanbeast
Date:September 1st, 2004 11:30 am (UTC)
(Link)
There is no bug :)
[User Picture Icon]
From:kunzite1
Date:September 1st, 2004 12:51 pm (UTC)

(Link)
i was out for about an hr and you are correct. not a fotobilder bug but that the user's settings were a little off.
(Leave a comment)
Top of Page Powered by LiveJournal.com