?

Log in

No account? Create an account
 

Bug report: post by email

About  

Previous Entry Bug report: post by email Aug. 20th, 2004 @ 03:05 pm Next Entry
When I post to my livejournal by email with images as attachments, the images are correctly uploaded to my pics.livejournal.com account but the post in my livejournal does not have working image tags:

<lj-cut text='2 images'><a href='http://pics.livejournal.com/cmshaw/pic/00004z9p/'><img src='http://pics.livejournal.com/cmshaw/pic/00004z9p/s320x240' alt='platypus.jpg' border='0'></a><br /><a href='http://pics.livejournal.com/cmshaw/pic/00005rrz/'><img src='http://pics.livejournal.com/cmshaw/pic/00005rrz/s320x240' alt='drublack.jpg' border='0'></a><br /></lj-cut>

The "/s320x240" string at the end of the SRC value appears to be the problem; when I edit the post to remove it, the images appear correctly. The links function correctly. (This is from a private test post, so the links will not actually function for anyone else.)

This "/s320x240" string is occurring on every image post I attempt. I thought it might be the image size at first, but these images are 160x120 and 100x100, respectively....
Leave a comment
[User Picture Icon]
From:mahlon
Date:August 20th, 2004 01:10 pm (UTC)
(Link)
Ahhh yes. I forgot to check the image size being uploaded when adding the scaling to the img url - we don't allow images to be scaled larger than they already are, just smaller.

Good catch, I'll be commiting a fix shortly.
[User Picture Icon]
From:cmshaw
Date:August 20th, 2004 02:01 pm (UTC)
(Link)
Thanks! (I've been working with smaller files because the large ones don't seem to be working -- I know there's a 30 MB limit, but emailing a 28 KB image seems to be failing.)
(Leave a comment)
Top of Page Powered by LiveJournal.com